RingCentral - Calls Not Being Received on Mobile Application

Incident Report for IT Specialists Status Page

Resolved

This incident has been resolved
Posted Jun 10, 2026 - 13:50 MDT

Monitoring

RingCentral have informed that they have implemented a fix and are monitoring to confirm the issue is resolved.
If you are still experiencing problems receiving calls on mobile, or would like to confirm your call history with us, get in touch.
Posted Jun 10, 2026 - 13:25 MDT

Investigating

RingCentral have informed that some customers are unable to receive calls on the Mobile Application.
We recommend keeping the Desktop Application open if possible, to be able to see when calls are coming in.

If you need assistance setting up the Desktop Application, or would like to confirm if you have missed any calls, please get in touch
Posted Jun 10, 2026 - 13:03 MDT
This incident affected: RingCentral.